0 голосов
спросил от в категории PHP
См. #PHP: Installation - Manual: Configuring PHP with OCI8 # [#^ #]:
Цитата:
При использовании клиентских библиотек Oracle 10gR2 в Windows раскомментируйте расширение строки php.ini=php_oci8.dll. При использовании клиентских библиотек Oracle 11gR2 или более поздних версий uncomment extension=php_oci8_11g.dll или extension=php_oci8.dll. В библиотеках Oracle 12c используйте расширение=php_oci8_12c.dll или extension=php_oci8_11g.dll или extension=php_oci8.dll.
Только одна из этих DLL может быть включена одновременно . DLL с более высокими версиями может содержать больше функциональных возможностей. Не все библиотеки DLL могут быть доступны для всех версий PHP. Убедитесь, что extension_dir установлен в каталог, содержащий DLL расширения PHP .

См. также раздел <код> Устранение неполадок :
br>
Цитата:
Самая распространенная проблема с установкой OCI8 - это не правильно настроить среду Oracle. Это обычно появляется как проблема с использованием oci_connect () или oci_pconnect ().

Цитата:
В Windows , имея несколько версий Oracle на одной машине, может легко вызвать столкновение библиотек, если не будет предпринята осторожность, чтобы убедиться, что PHP использует только правильную версию Oracle.

Ваш ответ

Отображаемое имя (по желанию):
Конфиденциальность: Ваш электронный адрес будет использоваться только для отправки уведомлений.

Категории

Добро пожаловать на сайт DraftingCode Q&A (ИТ ответы), где вы можете задавать вопросы и получать ответы от других членов сообщества.

Связанных вопросов не найдено

...